The forums are open again

July 10th, 2007 by Ben Goldacre in bad science | 7 Comments »

Okay, they’re still ugly, they still need a different login (email me when you register here to be activated for the forums, non-spammers). Quite possibly some time soonish the badsciencegeeks developer group will have unified logins between the blog and the forum, and everything will be pretty and look the same.

If you like what I do, and you want me to do more, you can: buy my books Bad Science and Bad Pharma, give them to your friends, put them on your reading list, employ me to do a talk, or tweet this article to your friends. Thanks! ++++++++++++++++++++++++++++++++++++++++++

7 Responses

  1. Nickynockynoonoo said,

    July 13, 2007 at 12:56 pm

    Thanks to all concerned. I’ve really missed my daily fix.

  2. germslayer said,

    July 13, 2007 at 10:26 pm


  3. Ambrielle said,

    July 17, 2007 at 2:50 pm

    Okay, help! I’m trying to login to the forums and being a complete interweb illiterate, I’m just getting a blank screen in response to logging in. I know it’s either something I’m doing, or something I’m not doing. Anyone got some advice before I go email Ben? Cheers.

  4. Robert Carnegie said,

    July 18, 2007 at 2:17 am

    Hmm. I think I was still logged in from the previous version of the site – a good trick. But on a re-visit I’m logged out and I’ve logged in – successfully. No problem as described. Maybe go back and start again? Delete cookies that belong to for a clean slate (that will also disconnect you from the blog – risky)? What web browser are you driving?

    You see it -is- just you :-)

  5. Ijon Tichy said,

    July 20, 2007 at 11:48 am

    I tried to register a while ago, but whenever I try to log on to the fora, I get a blank screen. What am I missing (I mean apart from my marbles)?

  6. Robert Carnegie said,

    July 20, 2007 at 8:50 pm

    You know it’s not
    – which says
    “The Bad Science Forums
    are hereā€¦

    At I think you should see a list of forums – “Bad Science”, “Meaningless Banter” etc., and an option to “Login”.

    That takes you to –
    “Please enter your username and password to log in.”

    Which I do, and it seems to work.

    You’ve noticed the other bit that says “email ben at badsnience dock dent with you username when you register, to activate” ?

    If you’re still stuck then it probably is time to call for help.

    But one other thought… maybe some Internet don’t-see-nasty-things software has been set to consider Ben’s new online home to be a nasty thing. After all, he’s now a stablemate of Richard Stallman, and also Ben has videos of things. Some people don’t like that.

  7. diudiu said,

    December 21, 2009 at 6:28 am

    free shipping ugg
    free shipping ugg